[CentOS] Re: mysqld breaks yum, help?

Dac Chartrand dac.chartrand at gmail.com
Sat Oct 4 23:02:18 UTC 2008

Hi all. Thanks for reading and replying.

> Isn't there php in the CentOS plus repo? What repo is that you
> messed about with? ATRPMS or Livna?

These don't have the latest versions of PHP5, the repo I am using is  
"Jason's Utter Ramblings Repo" @ www.jasonlitka.com and the only  
files I pulled from it are:

php.i386  5.2.6-jason.1
php-bcmath.i386  5.2.6-jason.1
php-cli.i386  5.2.6-jason.1
php-common.i386   5.2.6-jason.1
php-gd.i386  5.2.6-jason.1
php-mbstring.i386  5.2.6-jason.1
php-mysql.i386  5.2.6-jason.1
php-pdo.i386  5.2.6-jason.1
php-pgsql.i386   5.2.6-jason.1

> Again, do:
> rpm -q mysql mysql-server python

Results are as expected:

$ rpm -q mysql mysql-server python

$ yum list installed
mysql.i386  5.0.45-7.el5
mysql-server.i386  5.0.45-7.el5
python.i386  2.4.3-21.el5

I'll re-iterate for good measure:  `yum list php` doesn't work if  
mysqld is turned on. If I do `/etc/init.d/mysqld stop` (or `services  
mysqld stop`), `yum list php` works fine. So it's only failing when  
mysqld is turned on. (?!) And only on some commands. For example `yum  
list installed` works all the time.

Here's the full error:

]$ yum list php
Loading "fastestmirror" plugin
Loading "priorities" plugin
Loading mirror speeds from cached hostfile
  * utterramblings: www.jasonlitka.com
Traceback (most recent call last):
   File "/usr/bin/yum", line 29, in ?
   File "/usr/share/yum-cli/yummain.py", line 105, in main
     result, resultmsgs = base.doCommands()
   File "/usr/share/yum-cli/cli.py", line 289, in doCommands
   File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 85,  
in _getTs
   File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 91,  
in _getTsInfo
     self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
   File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 537,  
in <lambda>
     pkgSack = property(fget=lambda self: self._getSacks(),
   File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 392,  
in _getSacks
   File "/usr/lib/python2.4/site-packages/yum/repos.py", line 214, in  
   File "/usr/lib/python2.4/site-packages/yum/repos.py", line 66, in  
   File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 169,  
in run
     func(conduitcls(self, self.base, conf, **kwargs))
   File "/usr/lib/yum-plugins/fastestmirror.py", line 90, in  
     repomirrors[str(repo)] = FastestMirror(repo.urls).get_mirrorlist()
   File "/usr/lib/yum-plugins/fastestmirror.py", line 142, in  
   File "/usr/lib/yum-plugins/fastestmirror.py", line 155, in  
   File "/usr/lib/python2.4/threading.py", line 416, in start
     _start_new_thread(self.__bootstrap, ())
thread.error: can't start new thread

Other than installing packages using yum, and modified /etc/services  
and removed /etc/rpc for security reasons, nothing much has been done  
with this system. I'm at a loss to understand why it doesn't work  
when mysqld is turned on.

Any other ideas?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20081004/b209ade5/attachment.htm

More information about the CentOS mailing list