[CentOS] Re: smartd and 3ware on centos5

Aleksandar Milivojevic alex at milivojevic.org
Mon Oct 13 04:09:20 UTC 2008

Thanks to Tim Verhoeven who pointed me towards the right direction.

I've checked 3ware web site, and found newer version of tw_cli, which
worked.  It also created /dev/twe* devices (I have an "older" 8006-2LP
card, newer cards use twa* devices).  That solved problem with tw_cli

For smartd, I had to change /dev/sda to /dev/twe0 (I guess in the past
specifying /dev/sda in smartd.conf worked too).  However, than SELinux
kicked in.  The problem was that tw_cli created devices but did not
set correct context for them (they inherited it from parent dir).
Running restorecon on /dev/twe* solved the problem partially (on
reboot, the devices were gone, of course).  I've found some references
that smartd was supposed to create devices on startup if /dev/twe0 is
used in smartd.conf, but it didn't do it my case.  Hm, maybe it does
it for twa devices only, who knows...  Anyhow, I solved both problems
(device creation during boot and setting correct SELinux context) fast
and dirty way, by creating nodes in /etc/udev/devices with correct
permissions and SELinux context.

I've also found this relevant bug:

Looks like the bug was resolved by hacking smartmontool.  Though, I
wish they went with original proposal and fixed the device driver
instead, so that udev would automatically create devices during boot
if 3ware card is present in the system.

Once again, thanks to Tim for pointing me into right direction.

More information about the CentOS mailing list