[CentOS] CGI configuration - second post

tech tech at laamail.com
Fri Oct 17 08:12:24 UTC 2008

This is my second request for help with this problem. I have followed 
the suggestions given the first time and made some progress but I still 
have one final problem/question.

I have two CGI scripts that don't work. One is the standard Set-Cookie, 
examples can be found all over the net, that sets a cookie and prints 
"Your cookie name is set." The other is an automatic installation script 
that comes from commerce-cgi.com and is for installing their CGI 
shopping cart.

Both of these scripts are now located in /var/www/cgi-bin/ and the 
folder and the scripts are set to apache:apache 755. BTW a setting of 
root:root also fails exactly the same way.

If I run either of these scripts from a browser using www.domain.com it 
fails. If I run it from a browser using 
www.domain.com/cgi-bin/install.cgi or 
www.domain.com/cgi-bin/techtest.cgi it works.

I have tried using a one line index.shtml file with that one line being 
either <!--#include virtual="/cgi-bin/install.cgi"--> or <!--#exec 
cgi="/cgi-bin/install.cgi"--> and they both fail.

They do find and execute the script. The set cookie script prints the 
"Your cookie name is set." message OK but the cookie is not sent to the 
browser. The install script loads the first HTML page ok but does not 
load the second page.

I had a friend-of-a-friend IT guy that I trust look at everything. He 
hasn't found anything obvious. If he tries to run either of these 
scripts from his computer, it works OK.

Can someone here help me understand why this is happening?


PS posts in other online places (as suggested here) did not get any replies.

More information about the CentOS mailing list