[CentOS] cannot start Mysql

William L. Maltby CentOS4Bill at triad.rr.com
Sun Oct 19 17:45:49 UTC 2008

On Sun, 2008-10-19 at 18:01 +0100, Obantec Support wrote:
> <snip>

> Hi
> i tried /etc/init.d/rc.d/mysqld start
> mysqld does not exist on the server.

I suspect there are some docs on your system that describe what's
needed. I don't use it for anything not part of the normal system
install, so I can't be sure of that.

> no /var/lib/mysql/mysql.sock
> no /var/run/mysqld/mysqld.pid
> no /var/log/mysqld.log
> this is a clean install from CentOS DVD iso.
> i tried the mysqld script from my FC3 install and got the following

Since EL5 is based on FC6 (IIRC), not surprising.

> /etc/rc.d/init.d/mysqld: line 11:
> : command not found
> <snip a bunch of similar lines>

> chown: `mysql:mysql': invalid user
> Initializing MySQL database:  /etc/rc.d/init.d/functions: line 498: 
> /usr/bin/mysql_install_db: No such file or directory
> chown: `mysql:mysql': invalid user
> /etc/rc.d/init.d/mysqld: line 108:
> : command not found
> I get the feeling i need use yum to get some more mysql packages. big clue 
> is previously user:group mysql:mysql are set-up by an rpm.

Again, I don't use it. But I suspect that any mysql component
installation (or the even base install as a default installation) could
set up user and group entries. But my 5.2 doesn't have it, so probably
not one of those two situations.

> rpm -qa | grep mysql
> mysql-5.0.45-7.el5
> is installed
> the DVD has devel and server rpm's which i think as a minimum need to be 
> installed.
> Mark 
> <snip>

I don't use it myself, but maybe there's a clue below? The difference is
I don't have the c5-media enabled. If you have yours available, you
would leave it enabled.

# yum --enablerepo=\* --disablerepo=c5-media groupinfo 'MySQL Database'
Setting up Group Process
Checking for new repos for mirrors

Group: MySQL Database
 Description: This package group contains packages useful for use with
 Mandatory Packages:
 Default Packages:
 Optional Packages:

Maybe one of those is what you need? Check the installed, use yum info
to find out which, etc.

In the future, please initially post a more appropriate amount of
information describing the problem, such as *symptoms* ("won't start" as
the only symptom is going to be ignored by a lot of folks that might be
able to help), pertinent components installed, what you've already
investigated and those results, etc.

And please snip portions of thread not need to maintain context, such as
useless signature lines, tangential conversation, etc.


More information about the CentOS mailing list