[CentOS] External ext3 USB Hard drive and selinux

Al Freundorfer freund at queensu.ca
Wed Oct 29 15:23:28 UTC 2008

I was directed to post this on the mailing list. See the following forum post 
as a reference.


I formatted my external ext3 372GB USB hard drive in ubuntu and now want to 
use it 
in Centos. I made sure that my group/user numbers were the same. I was not 
able to write to the mounted USB hard drive (HD). I suspected selinux and 
shut it of and I was able to copy the file! I set selinux back to enforce and 
rebooted. I like the security features of selinux.

I tried:
1) chcon -v
2) restorecon -Rv /media/disk
3) cp -P

and still am not able to write to the USB HD. The sad part is I can delete 
files from the USB HD. See forum post for details.

I tried it in fedora 9 and it is able to write to the USB HD

I tried an 32GB USB memory stick in Centos 5.2 and it worked!
I am wondering why it doesn't work for my USB HD? The only difference is the 
the size.

Your help would be much appreciated.

More information about the CentOS mailing list