[CentOS] USB flash drive and VMs (Was Curmudgeoning)

Wed Sep 3 15:41:18 UTC 2008
David G. Miller <dave at davenjudy.org>

Anne Wilson <cannewilson at googlemail.com> wrote:

> Can't argue with you  :-)   It does seem likely, as 1GB flash drives wouldn't 
> have been a possibility at that time.  I never owned one at all until 
> relatively recently.
>>> > > They didn't work in 98 first edition, nor in NT4 or Win2000 - again, from
>>> > > memory, which could be faulty.
>> >
>> >  In Win2k, Micro$oft finally got up to speed and most flash drives
>> > will work with it, but XP is better.
>> >
> Fair enough.  Out of curiosity - do they work in W2K out of the box, or 
> require some update?  I ask because I'm considering W2K as a 
> VM.
> Anne
Flash support under qemu seems to be about the same as CD-ROM support.  
That is, you can access a device present at start up but it's not 
swappable.  Given:

[dave at bend ~]# lsusb
Bus 001 Device 002: ID 154b:0005 PNY
Bus 001 Device 001: ID 0000:0000 
Bus 002 Device 001: ID 0000:0000 

you can attach the device to a W2K qemu session by starting qemu with 
something like:

qemu -usb -usbdevice tablet -hda w2k.img -usbdevice host:001.002 -m 256 
-localtime &

I tried swapping two different 1GB thumb drives and the content of the 
drive wasn't visible after the swap.

If you decide to go the qemu route for a VM with W2K, I wrote about the 
problems I ran into on my blog at:


Getting a basic W2K VM working was fairly easy but getting it fully 
updated was a real pain.  I still have a couple of MS updates that I 
can't apply since W2K stops working if I do.


Politics, n. Strife of interests masquerading as a contest of principles.
-- Ambrose Bierce