[CentOS] CentOS 5 on an MSI Wind U100 Netbook && RTL8187 wireless card configuration

Fri Sep 12 09:38:42 UTC 2008
Niki Kovacs <contact at kikinovak.net>


I recently purchased an MSI Wind Netbook, just slightly bigger than an 
EeePC, and IMHO just one step above the mere toy category. It's got a 
10" monitor, 80 GB SATA HD, and the keyboard is just big enough so I can 
type with ten fingers (with a little exercise). The thing came 
preinstalled with Windows XP, and I've spent the last two days figuring 
out how I could possibly install my favourite OS on it. Among the many 
hairy details: 1) there's no CDROM nor floppy, only USB, and 2) the NIC 
is an RTL8101, not handled by the install kernel (nor the normal CentOS 
kernel). There were several Catch22's, but here's how I went about it. I 
published my detailed install notes (in French, but the Linux bits are 
universal :oD), since it seems to be a quite popular bit of hardware:


There's one exception though: the wireless card is a Realtek RTL8187 
(which lspci lists as RTL8199 Unknown device). I must have tried about 
ten different drivers out there, none of them worked (MSI only published 
precompiled kernel modules for SuSE Linux Enterprise 10, go figure). The 
ndiswrapper solution didn't work either: the Windows driver loaded OK, 
but no signal. I tried the dkms-rtl818x driver from RPMForge, but to no 
avail. Any suggestions on this piece of hardware?