[CentOS] cron job not working

Wed Sep 17 00:25:23 UTC 2008
bruce <bedouglas at earthlink.net>

hey al...

what are the privs that the cron is being run as. the cron should be root.
what are the acls for the dir that you're writing to??

it's probably a simple priv/acl issue....

-----Original Message-----
From: centos-bounces at centos.org [mailto:centos-bounces at centos.org]On
Behalf Of Al Sparks
Sent: Tuesday, September 16, 2008 5:01 PM
To: Centos List
Subject: [CentOS] cron job not working

Here's a perl script that works when I run it manually.  But when I
run it via cron, it won't create the directory.  But worse than that,
an email isn't sent to the account running the job.  So I'm not
getting an error, but it does work when I run it manually.

If I put an obvious error in the script, cron does generate an
email giving me the STDERR.

What could it be?
    === Al


($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst) = localtime(time);

# Above functions, "time" and "localtime", return weird $year and $month
# Need to be converted to become human readable

$year = $year + 1900;
$mon = $mon + 1;

# Want $mday and $mon to be 2 digits, with leading zero if necessary

$mday = "0" . $mday if $mday < 10;
$mon = "0" . $mon if $mon < 10;

# Second parameter is mask in octal

chdir "/ora-local/db-test-backups";
mkdir "${year}_${mon}_${mday}", \00022;
####End perl script

CentOS mailing list
CentOS at centos.org