[CentOS] USB DVD drive disappearing during kickstart install.

Thu Sep 18 12:27:46 UTC 2008
John <jses27 at gmail.com>

-----Original Message-----
From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf
Of Alex Tang
Sent: Thursday, September 18, 2008 3:28 AM
To: centos at centos.org
Subject: [CentOS] USB DVD drive disappearing during kickstart install.

Hi folks.

I maintain a bunch of centos based machines that are built using a somewhat
stripped down (limited number but mainly stock rpms) centos distro.  The
installation process is plain anaconda stuff with a 
kickstart file on the root of the DVD/iso.   The current hardware and 
media i'm using is DVD based.

On machines that have internal DVD drives (all IDE CD/DVD drives),
everything is fine.  However, I'm having a problem that started in 4.6 and
continues in 4.7 on machines that don't have an internal DVD drive and
therefore i must use a USB DVD drive.  On these machines, everything goes ok
in the beginning.  The DVD is "seen" by the machine and boots fine, the
isolinux screen comes up and i let the timeout go or i hit return to
continue.  Then, almost immediately thereafter, (when i should see the blue
screen with text about loading drivers) i see the blue screen with the
prompt for language.  This is supposed to be a kickstart install, so at this
point i know i'm hosed. 

If I use alt-f3 or alt-f4 (can't remember which one), i can see an error
message saying that the usb-storage driver is loaded, but it cannot find any
USB storage devices to read from. 

If i alt-f1 back to the main blue screen with the language prompt, i can go
through the prompts for language, keyboard, however when i get to "install
type", and select "usb cdrom" (i can't remember the text exactly...the
machines are in the server room, and i'm at my desk ATM), it fails again.  I
can alt-f3 back to see that the same error about loading the usb-storage
driver was successful but it can't find any attached usb storage device.
Unfortunately, at this point, there's no shell yet available in alt-f2, so i
can't poke around much).

It seems like somehow, something is happening like the USB bus is being
reset and it's "loosing" the usb devices and they can't be found anymore. 

Note that the original boot occurred of the DVD drive (i got past the
isolinux screen), so it's at least working in the beginning to get that far.

I had seen this problem occur a handful of times in the past in my same
distro based on CentOS-4.5, however it was sporadic and was usually solved
by changing the manufacturer of DVD drive (i thought it was a hardware
vendor not implementing the USB spec properly since most devices
worked...only a handful didn't).  However, since moving to 4.6 and also in
4.7, this problem is completely repeatable with all USB DVD drives i have
(granted it's only 3 different vendors/models, but they all don't work,
whereas all 3 of these used to work in the 4.5 based distro).

Also, as i stated earlier, on machines with internal DVD drives (IDE based),
everything works fine. 





JohnStanley Wrote:

Alex, have you tried setting the USB Option in the BIOS to Autodetect
between USB 1.0 and 2.0? That is if your machines BIOS supports that option.
Plugable USB drives are nice additions but my opinion is there not so good
at OS Installation, but don't get me wrong they are nice to boot a running
centos install to repair an install on a broken machine.. What about doing a
network install or VNC install from your desk?

Good Luck,