[CentOS] 5.2-5.3 Xen upgrade weirdness

Fabian Arrotin fabian.arrotin at arrfab.net
Wed Apr 1 13:59:13 UTC 2009

Tom Diehl wrote:
> Hi,
> Has anyone tried upgrading xen domu's from 5.2 to 5.3? I just did a 
> yum upgrade glibc & yum upgrade yum. All appeared to go well but when I 
> rebooted and tried to connect to the network, I could not. Looking at 
> /etc/sysconfig/network-scripts I see that the that there is now an ifcfg-eth0
> and an ifcfg-eth0.bak. ifcfg-eth0 now contains configuration for a dynamically
> configured interface and ifcfg-eth0.bak has the old static config information.
> In addition, the mac address of the interface has also been changed. I can put
> everything back but I would like to know if this behavior is deliberate? If so
> how do I revert whatever is making the changes so that this does not happen.
> I have software on some of my domu's that requires me to go get new license
> keys when mac addresses or ip addresses change.
> So far in my limited testing this only seems to happen on the domu. The dom0 
> seems to be OK, although I have not yet rebooted it.
> I did not see anything in the release notes.
> Regards,

We have updated several domU's i386 and x86_64 during QA tests and we've 
never seen that behavior.

Fabian Arrotin
  idea=`grep -i clue /dev/brain`
  test -z "$idea" && echo "sorry, init 6 in progress" || sh ./answer.sh

More information about the CentOS mailing list