[CentOS] can't "make"

Jim Perrin jperrin at gmail.com
Sun Apr 5 14:30:55 UTC 2009

On Sun, Apr 5, 2009 at 10:25 AM, Michael Klinosky <mpk2 at enter.net> wrote:
> Hello.
> I just fresh-installed 5.3 onto my laptop, and I have a problem trying
> to get wifi working. Be aware that I have 5.2 on it, and did the same
> process, and it worked great!
> I'm using http://wiki.centos.org/HowTos/Laptops/WirelessAR5007EG  -- as
> I did for 5.2. The problem arises in section 6:
> [mpk at a3680 madwifi-hal-]$ make
> /bin/sh: line 0: cd: /lib/modules/2.6.18-128.el5/build: No such file or
> directory
> Makefile.inc:66: *** /lib/modules/2.6.18-128.el5/build is missing,
> please set KERNELPATH.  Stop.
> [mpk at a3680 madwifi-hal-]$ ls
> ath       BuildCaps.inc  hal      kernelversion.c  Makefile.kernel
> README      release.h  THANKS
> ath_hal   contrib        include  Makefile         net80211
> README.dfs  scripts    tools
> ath_rate  COPYRIGHT      INSTALL  Makefile.inc     patch-kernel
> regression  SNAPSHOT
> Q: 'make' can be run as $ - correct?
> In another terminal:
> [root at a3680 tmp]# whatprovides build
> -bash: whatprovides: command not found
> [root at a3680 tmp]# rpm -q gcc gcc-c++ make kernel-devel
> gcc-4.1.2-44.el5
> gcc-c++-4.1.2-44.el5
> make-3.81-3.el5
> kernel-devel-2.6.18-128.1.6.el5
> I haven't a clue what's going on here, or how to fix it. Google's linux
> SE couldn't find any hits.

Seems you don't have the kernel-devel package installed for the kernel
you're running.

Your build error is for 2.6.18-128, but your kernel-devel is for
-128.1.6. Mostly, your problems should be solved if you run a 'yum
update' and reboot. This will ensure that you've got the updated
kernel (you probably already do, but a yum update will make sure) and
that your kernel matches the kernel-devel package you have installed.

During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell

More information about the CentOS mailing list