[CentOS] can't "make" - SOLVED

Scott Silva ssilva at sgvwater.com
Wed Apr 8 00:43:51 UTC 2009

on 4-5-2009 8:38 AM Michael Klinosky spake the following:
> Jim Perrin wrote:
>> Your build error is for 2.6.18-128, but your kernel-devel is for
>> -128.1.6. Mostly, your problems should be solved if you run a 'yum
>> update' and reboot. This will ensure that you've got the updated
>> kernel (you probably already do, but a yum update will make sure) and
>> that your kernel matches the kernel-devel package you have installed.
> I noticed this:
> ---> Package kernel.i686 0:2.6.18-128.1.6.el5 set to be installed
> Interesting!
> Well, I updated, rebooted and tried again - it worked!!   :)
> Thank you!
> I asked about 'make' as $ (I recall someone stating on a maillist that $ 
> could 'make', but # had to 'make install'). Seems that's wrong; I had to 
> be root to make.
> Is there a log of 'yum update' results?
> Btw, just in case I confused anyone:
>  > Be aware that I have 5.2 on it, and did the same
>  > process, and it worked great!
> I meant to type "... I had 5.2 on it, ..."  :)
No one said that root can't compile, it is just not safe to do so. You usually
compile as a user, and install as root. ($ and #)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 258 bytes
Desc: OpenPGP digital signature
Url : http://lists.centos.org/pipermail/centos/attachments/20090407/a0362c91/attachment.bin 

More information about the CentOS mailing list