[CentOS] Trouble with 5.2==>5.3 upgrade

Blake Hudson blake at ispn.net
Wed Apr 8 16:47:12 UTC 2009

-------- Original Message  --------
Subject: Re: [CentOS] Trouble with 5.2==>5.3 upgrade
From: fred smith <fredex at fcshome.stoneham.ma.us>
To: CentOS mailing list <centos at centos.org>
Date: Wednesday, April 08, 2009 11:37:57 AM
> On Wed, Apr 08, 2009 at 06:10:08PM +0200, Tru Huynh wrote:
> Thanks  for the quick reply!
>> On Wed, Apr 08, 2009 at 11:52:27AM -0400, fred smith wrote:
>>> I've updated two 5.2 systems without a hitch. But this third one is
>>> giving me some grief. See errors below.
>>> Googling for "Package does not match intended download" turns up a bunch
>>> of hits, but none of them (that I've seen) offers any working solution.
>>> Can someone suggest how to overcome the following error(s)
>>> Thanks a bunch!
>>> Downloading Packages:
>>> (1/1): kernel-2.6.18-128. 100% |=========================|  15 MB    05:41     
>>> http://centos.mirror.nac.net/5.3/updates/i386/RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm: [Errno -1] Package does not match intended download
>>> Trying other mirror.
>> http://mirror-status.centos.org/ is listing http://centos.mirror.nac.net/
>> as 2 days late, so you might have been hitting an incomplete mirror.
> Wouldn't surprise me. But I've tried this probably 10 times in the last
> 2-3 hours, would I always be that unlucky?
> And if so, how would I avoid that mirror?
>>> http://ftp.lug.udel.edu/pub/centos/5.3/updates/i386/RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm: [Errno 9] Requested Range Not Satisfiable
>> You probably have a (transparent?) proxy server on the way.
>> "Requested Range Not Satisfiable" for all the others since the remaining public
>> centos mirrors are listed as 'current'
> No proxies here. possibly someone "upstream" from here has one...
There's already a thread on this issue - "Update from 5.2 to 5.3 kernel 
not on mirror"

I worked around the issue by updating the kernel through RPM vs yum, 
then performing the yum upgrade.

The issue is not a proxy (as we do not have one installed, nor one 
upstream) - and, as you mentioned (and was the case with me), the 
upgrade worked fine on several boxes on the same network. The problem 
appears to be with the CentOS repos, affecting anyone on CentOS 5.2 with 
an older kernel trying to upgrade directly to 5.3 (as far as I can tell).

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20090408/16911d3c/attachment.html>

More information about the CentOS mailing list