[CentOS] Trouble with 5.2==>5.3 upgrade

Les Mikesell lesmikesell at gmail.com
Wed Apr 8 18:16:50 UTC 2009

Blake Hudson wrote:
>>>> Downloading Packages:
>>>> (1/1): kernel-2.6.18-128. 100% |=========================|  15 MB    05:41     
>>>> http://centos.mirror.nac.net/5.3/updates/i386/RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm: [Errno -1] Package does not match intended download
>>>> Trying other mirror.

Do the mirrors sync in a way that lets the filename become visible 
before the sync is actually complete?

> I worked around the issue by updating the kernel through RPM vs yum, 
> then performing the yum upgrade.
> The issue is not a proxy (as we do not have one installed, nor one 
> upstream) - and, as you mentioned (and was the case with me), the 
> upgrade worked fine on several boxes on the same network. The problem 
> appears to be with the CentOS repos, affecting anyone on CentOS 5.2 with 
> an older kernel trying to upgrade directly to 5.3 (as far as I can tell).

I've had mixed results, even from boxes on the same network, behind the 
same proxy.  Perhaps coincidentally all x86_64 versions 'just worked' 
with only the 'yum update glibc\*' done first.  The 32-bit versions 
mostly had some missing packages that I had to exclude to get the first 
update to run, then after a 'yum clean all' and a few retries they would 
find the rest.  Apparently the clean is necessary to make a box change 
its mind about a previously determined fastest-mirror - but I thought it 
was supposed to still check others for missing packages.

   Les Mikesell
    lesmikesell at gmail.com

More information about the CentOS mailing list