[CentOS] Trouble with 5.2==>5.3 upgrade

fred smith fredex at fcshome.stoneham.ma.us
Wed Apr 8 19:22:47 UTC 2009

On Wed, Apr 08, 2009 at 12:19:42PM -0500, Blake Hudson wrote:
> -------- Original Message  --------
> Subject: Re: [CentOS] Trouble with 5.2==>5.3 upgrade
> From: fred smith <fredex at fcshome.stoneham.ma.us>
> To: CentOS mailing list <centos at centos.org>
> Date: Wednesday, April 08, 2009 11:58:28 AM
> >
> >
> >but since the file appears to download fine, it wouldn't be a case of 
> >"not on mirror", would it?
> >
> >  
> >>I worked around the issue by updating the kernel through RPM vs yum, 
> >>then performing the yum upgrade.
> >>
> >>The issue is not a proxy (as we do not have one installed, nor one 
> >>upstream) - and, as you mentioned (and was the case with me), the 
> >>upgrade worked fine on several boxes on the same network. The problem 
> >>appears to be with the CentOS repos, affecting anyone on CentOS 5.2 with 
> >>an older kernel trying to upgrade directly to 5.3 (as far as I can tell).
> >>
> >>--Blake
> >>    
> Well, while it is on the mirror - Yum will not download/install it. I 
> was able to download fine via wget and install via rpm.  I believe the 
> yum error "Package does not match intended download" is likely a better 
> indicator of the problem and the following "Requested Range Not 
> Satisfiable" errors are a byproduct - perhaps an error in yum or a 
> library it uses.
> I just found a thread entitled "Update fails with "Package does not 
> match intended download"" on the Centos PHPbb forums and it has a fix 
> (have not tried myself). The fix is to disable the fastestmirror plugin 
> by editing the /etc/yum/pluginconf.d/fastestmirror.conf
> http://www.centos.org/modules/newbb/viewtopic.php?topic_id=19479&forum=37

I actually tried "yum --disableplugin=fastestmirror" and it did not make
any difference.

Since the error says "did not match intended download" I'm guessing that
some of the metadata contains the sha1sum (or similar) and the downloaded
file had the wrong sum. I'm further guessing that it may be an error in
the metadata (if that's where it's store, I don't really know).

I finally, as someone else suggested, downloaded the desired kernel file
from one of the mirrors, did "rpm -uvh" on it followed by "yum -y update" 
and it all applied without complaint.

> I also found reference to the same error and problem during the CentOS5 
> -> 5.1 release. I'm not sure what the fastest mirror plugin is doing 
> (perhaps caching old data?), but it does not seem that it is being 
> tested thoroughly by Q/A during these respins.
> Perhaps this clue will help others...
> --Blake

> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

---- Fred Smith -- fredex at fcshome.stoneham.ma.us -----------------------------
  "For him who is able to keep you from falling and to present you before his 
 glorious presence without fault and with great joy--to the only God our Savior
 be glory, majesty, power and authority, through Jesus Christ our Lord, before
                     all ages, now and forevermore! Amen."
----------------------------- Jude 1:24,25 (niv) -----------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20090408/97015a03/attachment.bin 

More information about the CentOS mailing list