[CentOS] Using cdrecord on CentOS

Robert Heller heller at deepsoft.com
Wed Apr 15 15:55:42 UTC 2009

At Wed, 15 Apr 2009 15:46:20 +0200 CentOS mailing list <centos at centos.org> wrote:

> Michael A. Peters a écrit :
> >>
> >> 1) Am I supposed to be root to use cdrecord and burn an .iso file?
> > 
> > I've found it works much better if you are root.
> > 
> I tried both, and see: cdrecord complains about not being able to set 
> certain priorities while being run as user, which induces a high risk 
> for buffer underruns. So I have my answer for that.
> Another cdrecord-related question. Usually I should be able to copy a CD 
> as simply as that:
> $ dd if=/dev/cdrom of=copy.iso
> Then insert a blank CD, and:
> $ cdrecord -v -eject dev=/dev/cdrom copy.iso
> Now I did that for data CDs, and it works very well. I thought, normally 
> this *should* also work for audio CDs, so I gave that a spin. But 
> everytime I try it, dd stops short and gives me an "Input/output error" 
> for /dev/hdc.

While dd *can* be used to copy single-track data CDs, it is better to
use the readcd program (comes with the cdrecord package).  For audio
CDs, the cdda2wav program would be a better option.

> I tried three different audio CDs, all three in good state. I can listen 
> to them OK on the PC. But all I get with dd is a zero-byte-length 
> copy.iso file.

An audio CD is not like a data CD.  It does not have a 'file system'. 
It is a collection of data tracks, containing cdda files.

> Any idea what's happening?
> Niki
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Robert Heller             -- 978-544-6933
Deepwoods Software        -- Download the Model Railroad System
http://www.deepsoft.com/  -- Binaries for Linux and MS-Windows
heller at deepsoft.com       -- http://www.deepsoft.com/ModelRailroadSystem/

More information about the CentOS mailing list