[CentOS] Yum update corrupted something badly - can only get access through SSH terminal or Webmin

Lanny Marcus lmmailinglists at gmail.com
Wed Apr 22 20:17:48 UTC 2009

On 4/22/09, Les Mikesell <lesmikesell at gmail.com> wrote:
>>> On Wed, Apr 22, 2009 at 1:46 PM, Dan Roberts <dan at jlazyh.com> wrote:
>>>> that aside - I can't run the command you suggest because any yum
>>>> operation results in the same error message.
>>>> # yum clean all && yum update glibc\* && yum update
>>>> Traceback (most recent call last):
>>>>   File "/usr/share/yum-cli/output.py", line 26, in ?
>>>>     from i18n import _
>>>> ImportError: No module named i18n
>>> <http://www.centos.org/docs/5/html/5.1/Deployment_Guide/s2-sysconfig-i18n.html>
>>> Have you tried yum install i18n  ?

>> That wouldn't work because yum is broken?
>> Just my two cents.
> I have always wondered about the sanity of using python for system
> administration tools, but this should be a yum file in /usr/share/yum-cli/.

Les: Is i18n installed by Webmin during the Webmin installation?
Possibly he needs to add another yum repository? Lanny

More information about the CentOS mailing list