[CentOS] Yum update corrupted something badly - can only get access through SSH terminal or Webmin

Filipe Brandenburger filbranden at gmail.com
Wed Apr 22 21:06:32 UTC 2009


On Wed, Apr 22, 2009 at 16:00, Craig White <craigwhite at azapple.com> wrote:
> I wouldn't recommend that you use '--force' for any rpm commands unless
> you know what you're doing.

I suggested the --force just in case the RPM database already had the
yum package registered, but the package was corrupt.

I agree with your statement that --force should be only used if you
know what you're doing.

> Open a web browser and depending upon your installation (I am using i386
> here)...
> http://mirror.centos.org/centos/5/os/i386/CentOS/

I suggested that the OP gets the packages for 5.2, since his install
seems to be closer to a 5.2 than a 5.3. That way he may end up getting
yum to work again quicker, and then he can use yum to update his
system to the latest packages.

Using /5/ (CentOS 5.3) is also doable, but the number of packages he
will have to download and install manually will certainly be larger.


More information about the CentOS mailing list