[CentOS] mock %post(pam) failure

Mon Apr 13 16:03:47 UTC 2009
Stuart Jansen <sjansen at gurulabs.com>

On Mon, 2009-04-13 at 07:26 -0700, Akemi Yagi wrote: 
> On Mon, Apr 13, 2009 at 7:18 AM, Rex Dieter <rdieter at math.unl.edu> wrote:
> > interestingly, I can no longer reproduce this failure myself on a recently
> > upgraded centos-5.3 box using mock-0.9.14 (from epel).
> So, we can use mock-0.9.14 from EPEL on CentOS 5.3 (with the current
> CentOS yum) without any issue?

I'm using mock-0.9.14 on a fully updated CentOS 5.3 and yum is still
trying to install pam before coreutils.

Perhaps the problem is a configuration difference. For the most part,
I'm using a standard mock configuration. I have, however, disabled all
caching in site-defaults.cfg

Perhaps others aren't seeing this problem yet because they are using a
cached buildroot, but will have a problem once the cache is cleared. I
tried enabling caching, but it didn't make a difference.

For building, I use a copy of the CentOS core and update packages
rsync'd from a local mirror.

rsync -qaHz --numeric-ids --fuzzy --delete-excluded

I'm also using the latest buildsys packages from Fedora downloaded by

wget -q -rc -nv -nH -np -R '*=D,*=A' \

I have tried building with EPEL enabled and disabled. Neither helped.