[CentOS] A bit more on the Firefox 3.5.issue

Filipe Brandenburger filbranden at gmail.com
Tue Aug 11 21:06:30 UTC 2009


On Tue, Aug 11, 2009 at 13:06, David G. Miller<dave at davenjudy.org> wrote:
> I just checked the links with FF 3.5.2 under Fedora Core 11 and they open just
> fine.  This would seem to narrow the problem down to FF 3.5 on CentOS 5.3.
> Perhaps someone with a CentOS 4.X could give it a try (assuming FF 3.5 will
> install on CentOS 4.x).

I managed to run FF 3.5 in CentOS 4.x but I can tell you right away
that it's ugly...

I am using the binary install from the website, however it looks for
libdbus-1.so.3 and libdbus-glib-1.so.2 which are not present on C4
(only libdbus-1.so.0 and libdbus-glib-1.so.0 there). To work around
that, I created symbolic links pointing to the old versions... (Yes, I
know that it's really ugly, but I just had to get it running and it
worked sort of...).

I tried to rebuild it in C4 but had many build errors, it seems that
it will not build without a recent Xorg and fontconfig packages (among
maybe others). I am planning to build a Firefox 3.5 in C5 but
disabling DBUS support, which will at least alleviate the problem with
the libraries that are not present in C4...

Anyway, I tested those webpages with my FF 3.5 (binary) in C4 and they
work just fine... I have a couple of users that are using 3.5 all the
time, and they did not report any crashes or anything like that. I
only have a problem with one specific user, sometimes when she starts
it it complains about DBUS, then if I run it with -fail-safe parameter
it opens just fine, if right after that I close it and open it again
(without safe mode) it works. But the following day the same issue
will happen again... Anyway, she was having some display issues with
FF 3, so it's quite probable that she has something weird in her dot
files that is causing the issue just for her.


More information about the CentOS mailing list