[CentOS] Thunderbird installed for python dependency?

Bowie Bailey Bowie_Bailey at BUC.com
Tue Aug 25 14:09:22 UTC 2009


I was starting to run a yum update on one of my servers and noticed that
it wanted to install Thunderbird for some reason.  Running yum with the
'-v' option gave this output:

gamin-python-0.1.7-8.el5.i386 requires: /usr/lib/python2.4
--> Processing Dependency: /usr/lib/python2.4 for package: gamin-python
Needed Require is not a package name. Looking up: /usr/lib/python2.4
Potential Provider: python.i386 0:2.4.3-24.el5
Mode is u for provider of /usr/lib/python2.4: python.i386 0:2.4.3-24.el5
Mode for pkg providing /usr/lib/python2.4: u
Cannot find an update path for dep for: /usr/lib/python2.4
Searching pkgSack for dep: /usr/lib/python2.4
Potential match for /usr/lib/python2.4 from python-2.4.3-24.el5.i386
Potential match for /usr/lib/python2.4 from
thunderbird-2.0.0.22-2.el5.centos.i386
python-2.4.3-24.el5.i386 is in providing packages but it is already
installed, removing.
TSINFO: Marking thunderbird-2.0.0.22-2.el5.centos.i386 as install for
gamin-python-0.1.7-8.el5.i386

Why is it trying to get the python lib from Thunderbird when the Python
package is already installed?

I don't really want Thunderbird installed on a server.  Any suggestions?

Thanks

-- 
Bowie



More information about the CentOS mailing list