[CentOS] CentOS DHCP Server

Kemp, Larry Larry.Kemp at usmetrotel.com
Tue Dec 8 21:03:03 UTC 2009

CentOS Community,

I need help with a CentOS DHCP server.

I have a simple 32bit CentOS 5.3 server running on an Intel chip server in a lab environment with two NIC's. 

eth0 - Is connected to the Internet using a static public IP address.
eth1 - Is connected to a private LAN with no other access to the web. 
	 Runs DHCP to the internal client systems.
       Is the default gateway for all LAN traffic to the Internet.
       Runs iptables as the firewall between the LAN and the Internet.

On eth1 DHCP was running with no problems for some time. This lab system sat for months untouched and then we revisited this product/project only to find that DHCP would not start. It gave us this following error:

	Failed to start dhcpd : 
	Internet Systems Consortium DHCP Server V3.1.3
	Copyright 2004-2009 Internet Systems Consortium.
	All rights reserved.
	For info, please visit https://www.isc.org/software/dhcp/
	Wrote 0 leases to leases file.
	Listening on LPF/eth1/00:50:ba:c0:43:c7/10.1.1/24
	Sending on   LPF/eth1/00:50:ba:c0:43:c7/10.1.1/24
	Can't bind to dhcp address: Address already in use
	Please make sure there is no other dhcp server
	running and that there's no entry for dhcp or
	bootp in /etc/inetd.conf.   Also make sure you
	are not running HP JetAdmin software, which
	includes a bootp server.   

There is no other DHCP server on this LAN or on the public /30 that eth0 connects to (not that eth0 would impact my internal LAN). 

I saw there were ofcourse many systems updates for CentOS and thought that a might resolve. It did not.

I then downloaded many versions of ISC's DHCP and compile and tried each of them from source code. This problems still exists. I have tried even the very simplest of dhcp.conf files and DHCP will still not start. Have I found a bug in the ISC DHCP code? Unlikely. I hope that one of you has run into this before and can help me out. Thanks greatly in advance.       


Larry Kemp
Network Engineer
U.S. Metropolitan Telecom, LLC
Bonita Springs FL USA

More information about the CentOS mailing list