[CentOS] Is lsb 3.2+ detrimental to CentOS 5.4?

MHR mhullrich at gmail.com
Thu Dec 10 06:23:16 UTC 2009

I found out today that Google Chrome is now available for Linux.
However, and this is a big but:

$ sudo rpm -ivh google-chrome-beta_current_x86_64.rpm
warning: google-chrome-beta_current_x86_64.rpm: Header V3 DSA
signature: NOKEY, key ID 7fac5991
error: Failed dependencies:
        lsb >= 3.2 is needed by google-chrome-beta-
        xdg-utils is needed by google-chrome-beta-
$ yum list | grep -i lsb
redhat-lsb.i386                            3.1-12.3.EL.el5.centos      installed
redhat-lsb.x86_64                          3.1-12.3.EL.el5.centos      installed

I'm not that familiar with lsb, but from what I can find, it does not
seem like it would be a good idea to install a more recent version of
lsb than the official release, or am I way off base here?

I can get xdg-utils easily enough, but it doesn't seem relevant if I
can't use the newer lsb.

So, is it possible to use lsb 3.2+ on CentOS 5.4 without breaking
anything?  Is there anything else I'd need to do, other than convert
to Fedora (not going to happen)?



More information about the CentOS mailing list