[CentOS] Frustrations with MySQL loss, tcpdump, netstat, etc

John Kienitz jkienitz at yahoo.com
Tue Dec 22 15:00:43 UTC 2009

UPDATE mysql.user SET Password=PASSWORD('mypassword') WHERE User='root';
GRANT ALL ON mysql.* to 'root'@'';
GRANT ALL ON mysql.* TO 'root'@'localhost';
GRANT ALL ON mysql.* TO 'root'@'my home IP';

and I still cannot connect. But the database starts and this code executes because If I go to the console and run /usr/bin/mysql -u root -p and use this password from the update statement that password gets me in.

So, on my server I run tcpdump host <my ip> and I dont think I see anything where 3306 is coming through. 

if I run a test MySQL connection from the MySQL Workbench and they run netstat on my server
and I dont see a entry where 3306 is used in what netstat is dumping.

What am I doing wrong? What can I check for? I am stumped!


Try to telnet to port 3306 and see if you get thru.

Try changing the password after you have added the users with the GRANTS.  If you have run your script more than once that has probably been done.  Commit should probably be before the flush also.



More information about the CentOS mailing list