[CentOS] Frustrations with MySQL loss, tcpdump, netstat, etc

Tue Dec 22 14:34:30 UTC 2009
ML <mailinglists at mailnewsrss.com>

Hi All,

Hi All,

MySQL 5.0.77 on CentOS 5.4

MySQL is running, my Wordpress stuff is working, but I cannot connect to the server from my house. This server is in my house, however, but on a public IP, behind a firewall, etc.

I checked my hardware firewall (a dedicated UnTangle system) and that is successfully allowing the passage. I know this because the firewall shows:

2009-12-22 6:29:41 am passed <my IP>:35606 <server IP>:3306

I checked the firewall (system-config-securitylevel-tui) on the server and that has 3306:tcp allowed. 

When I try to connect I get an error (4) which when I google says: "Interrupted System call"
I have tried using the MySQL Workbench and other client software.

If I look in /var/log/mysqld.log I dont see anything but the fact the server started. 

I tried stopping mysql with /etc/init.d/mysqld stop

Then starting with mysqld_safe --init-file=/tmp/code.txt &

Where code.txt contains:

UPDATE mysql.user SET Password=PASSWORD('mypassword') WHERE User='root';
GRANT ALL ON mysql.* to 'root'@'';
GRANT ALL ON mysql.* TO 'root'@'localhost';
GRANT ALL ON mysql.* TO 'root'@'my home IP';

and I still cannot connect. But the database starts and this code executes because If I go to the console and run /usr/bin/mysql -u root -p and use this password from the update statement that password gets me in.

So, on my server I run tcpdump host <my ip> and I dont think I see anything where 3306 is coming through. 

if I run a test MySQL connection from the MySQL Workbench and they run netstat on my server
and I dont see a entry where 3306 is used in what netstat is dumping.

What am I doing wrong? What can I check for? I am stumped!