[CentOS] Autofs cannot bind LDAP server

Wed Dec 2 15:57:45 UTC 2009
Eric B. <ebenze at hotmail.com>

> "Kwan Lowe" <kwan.lowe at gmail.com> wrote in 
> message 
> news:b7e478370912020407p35def217td1bcf579d7bb83aa at mail.gmail.com...
> On Fri, Nov 27, 2009 at 12:30 PM, Eric B. 
> <ebenze at hotmail.com> wrote:
> > My problem, however, is that once my ldap server is back up, autofs 
> > never
> > seems to retry to connect to it, so all my /home mounts fail. Basically, 
> > it
> > means I have to make sure that my LDAP server is never down while 
> > another
> > server is rebooting.
> >
> > I figure there must be something in the configuration file that would 
> > allow
> > me to tweak this to indicate to autofs to recheck the ldap server
> > periodically to see if it has come back up, but can't seem to find 
> > anything.
> Once the server is back up, does restarting the autofs daemon fix the
> behaviour?

Yes.  Restarting autofs daemon causes it to reconnect to the ldap server, 
and all automounts work properly at that point.

> Also, try setting the logging to debug.. Might give you a better idea
> of why it's not reconnecting.

I tried, but I got not additional useful information out of the automounter. 
Basically, it says that it failed to connect to ldap server, and never 
retries.  But nothing particularly more useful (to me at least) there.

Any ideas of lists or groups that I can try otherwise?  I've tried posting 
to the kernel.autofs mailing list, but for some reason my posts never make 
it on.  I even tried mailing the list admins but got no response back from 
them either.