[CentOS] nvidia motherboard with mcp78b chipset

B.J. McClure keepertoad at bellsouth.net
Sat Jan 17 10:04:55 UTC 2009

On Sat, 2009-01-17 at 09:51 +0530, partha chowdhury wrote:
> Jerry Geis wrote:
> > Hi all,
> > 
> > I have a new motherboard I am trying to install centos 5.2 x86_64 on.
> > it has the mcp78b chipset.
> > 
> > seems like the SATA disk is not detected. tells me no install media found.
> > 
> > I tried the install line with "pci=nomsi" that did not help.
> > I tried changing the SATA in the bios to AHCI and that did not help.
> > 
> > Any thoughts on something to try?
> > 
> > Jerry


> you can download the CentOS live-cd version and run it and see how the 
> hardware is supported under the current version of CentOS
> > http://lists.centos.org/pipermail/centos-announce/2008-February/014688.html
I had a similar issue with an Asus M3N-HT series board with Nvidia 780a
chipset.  I was able to boot and install CentOS 5.2 x86_64 using passing
kernel option pci=nomsi even though I was never able to get the CentOS
live cd to boot.  lspci could not id the chip set either.  I was able to
boot several ubuntu live cd's to determine nic and audio driver.  I
doubt you will have a satisfactory driver for nic or audio with present
centos kernel.  Also tried rhel 5.3 beta kernel which appeared to work
without issue except still no support for nic or audio.  Finally
compiled vanilla kernel from kernel.org and everything works.

The point of all this rambling is that you may have to compile a custom
kernel to make everything work or go to a more bleeding edge

Google mcp78b tells me many are getting errors with 2.6.26. on that
chipset.  IIRC ubuntu 8.10 uses 2.6.27 kernel and might be the way to

Good luck.


CentOS 5.2, Linux 2.6.18-92.1.22.el5 athlon 04:41:30 up 12:02, 1 user,
load average: 0.63, 0.40, 0.17

More information about the CentOS mailing list