[CentOS] Keep lossing wireless - ipw3945

Wed Jul 15 19:25:18 UTC 2009
Robert Moskowitz <rgm at htt-consult.com>

Sunday I updated my kernel to 128.1.16 (I had to reboot so it was time 
to update).  No problems with wireless in my home.

Monday I started traveling to IEEE 802 plenary, and I have lost my 
wireless numerous times needing to reboot.

The symptom is the radio light goes off.  Back before the kernel update, 
this would happen sometimes at home while on battery, and I would just 
press the capacitor sensor and turn it back on, and I would get my 
signal back.

But so far this week, this has not worked.  Nothing.  No signal is 
gotten after turning the radio back on (for whatever reason this system 
decides to turn it off).

I have tried restarting the network and NetworkManager and this has not 
helped (this use to help in the past when I saw this behaviour).

There were some messages during the kernel update as follows:

Uninstalling: fuse 2.7.4-1.nodist.rf (2.6.18-128.1.6.el5) (i686)

-------- Uninstall Beginning --------
Module:  fuse
Version: 2.7.4-1.nodist.rf
Kernel:  2.6.18-128.1.6.el5 (i686)

Status: Before uninstall, this module version was ACTIVE on this kernel.
Removing any linked weak-modules
WARNING: Can't read module 
/lib/modules/2.6.18-128.1.6.el5/weak-updates/fuse.ko: No such file or 
WARNING: Can't read module 
/lib/modules/2.6.18-128.1.6.el5/weak-updates/fuse.ko: No such file or 

 - Uninstallation
   - Deleting from: /lib/modules/2.6.18-128.1.6.el5/extra/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


DKMS: uninstall Completed.
Uninstalling: ipw3945 1.2.1-1.nodist.rf (2.6.18-128.1.6.el5) (i686)

Error! The module ipw3945 1.2.1-1.nodist.rf is not currently installed.
This module is not currently ACTIVE for kernel 2.6.18-128.1.6.el5 (i686).
  Cleanup        : kernel                                            [6/6]

Removed: kernel.i686 0:2.6.18-128.1.6.el5 kernel-devel.i686 
Installed: kernel.i686 0:2.6.18-128.1.16.el5 kernel-devel.i686 
Updated: kernel-headers.i386 0:2.6.18-128.1.16.el5

But despite that unistalling ipw3945 message, wireless worked, or it seemed.

I am seeing log messages like:

Jul 15 10:35:28 nc2400 kernel: ipw3945: Detected geography ABG (11 
802.11bg chan
nels, 13 802.11a channels)

a lot.

When I lost the wireless and tried to restart everything I saw:

Jul 15 10:37:27 nc2400 NetworkManager: <WARN>  scan_results_cb(): could 
not get
scan results: An error ocurred getting scan results..

I really cannot deal with frequent rebooting.  Can someone point me in a 
direction to fix this?