[CentOS] CentOS, laptop & DLP

Mon Jul 20 02:25:10 UTC 2009
MHR <mhullrich at gmail.com>

I have an old Toshiba Tecra 8100 that I run CentOS on - it's running
5.3 although not completely up to date at the moment.

About a year ago, a club I help administer bought a BenQ DLP so we
could show movies and do other projector things more easily than
lugging around a 27" TV set.  It worked just fine, but the behavior of
the system with it has changed over the year and I'm curious if anyone
might know why.

When I first connected the DLP, the laptop (and CentOS) recognized it
immediately, and there was absolutely no trouble with it at all.  I
plugged it in, turned it on, hooked it up, and voila, it worked.

Now the laptop doesn't recognize the DLP unless I plug it in either
before booting, or reboot after it's plugged in, and I can't play with
the <function>-F5 combination (that switches between LCD, DLP,
LCD+DLP, no video) until I'm logged in unless I want to be stuck in
whichever mode it lands in.  I usually set it for both and wait until
my login is complete, then I can flip between all the settings just

One of the things I really liked about CentOS with this DLP at first
was that I did NOT need to reboot for the system to recognize and use
the DLP, just like any other hot-plug add-on.  I connect it via the
external 15-pin video port, same as day 1.

Am I missing something, like "be sure the projector is on (or off)
when I connect it to the laptop?  I think I've tried all possible
combinations of this and it just doesn't function at all unless I
(re)boot after the DLP is on and connected.

The only change I know for certain that happened over this year is
that I upgraded from 5.2 to 5.3, but I can't remember if this had
anything to do with the change in behavior or not (I don't think so,
but it's been over the course of a year...).