[CentOS] Web photo gallery options [Definitely solved]

Fri Jul 3 08:41:15 UTC 2009
Sorin Srbu <sorin.srbu at orgfarm.uu.se>

>-----Original Message-----
>From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On
>Of Ray Van Dolson
>Sent: Wednesday, July 01, 2009 4:32 PM
>To: CentOS mailing list
>Subject: Re: [CentOS] Web photo gallery options
>On Wed, Jul 01, 2009 at 11:45:05AM +0200, Sorin Srbu wrote:
>> >>FYI, gallery2 is available in EPEL for EL-5.
>> >
>> >I used the info available at
>> >http://www.cyberciti.biz/faq/rhel-fedora-centos-linux-enable-epel-repo/
>> >add the EPEL-repo.
>> Replying to myself... Googled some and found that Gallery2 is most
>> in the Fedora development repo. Now to find how I add this repo to
>Yeah, as you discovered, I think it's in the -testing repository of
>epel.  Usually involves editing on of your epel .repo files, enabling
>the -testing repo and then doing yum install gallery2*.
>  yum --enablerepo=epel-testing install gallery2*

Nice, thanks. I'll keep this for future reference. FWIW, I got some packages
from EPEL that weren't available from the CentOS-base and rpmforge repos,
like jhead or something like that. It really did come in handy, so thanks

Anyway, spent some time yesterday afternoon and evening and got Gallery2
running. I think I secured mysql properly as well as the gallery2 folders
and files. At least config.php is not readable by the world. Uploaded some
albums as well.

Only thing left is to figure out to disable commenting completely.

One strange thing I ran into was that mysqld wasn't available if I installed
mysql from the CLI. If I installed it using the Add/Remove applet in the
Start menu it was. I found that a bit strange...

For those interested, have a look at
http://home-skynet.servehttp.com/gallery2/main.php. Birds, motorcycles and
flowers. Mirrors my interests pretty well, not necessarily in that
particular order. And yeah, it's me on the green VFR. ;-)

*** Thanks all for really good help with this! ***
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5106 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20090703/7e41276b/attachment-0005.bin>