[CentOS] nfs (v3?) fails to allow writes and permission changes

Mon Jul 13 19:53:27 UTC 2009
Craig White <craigwhite at azapple.com>

On Mon, 2009-07-13 at 15:47 -0400, Rob Kampen wrote:
> Hi All,
> I have an nfs mount from my CentOS 5.3 client to a CentOS5.3 server. 
> This has been functioning correctly for some years.
> Beginning last week I had problems saving OpenOffice documents onto the 
> nfs mounted volume.
> OpenOffice just times out with a file io error.
> So I tried just a simple shell - cd to the mounted volume did a vi 
> create of text file - no problems.
> tried a chmod +w on an owned file - returned okay but no change to the 
> permissions when checked with ls -l
> tried sudo chmod +w on the same file and get
> [rkampen at robsws p_494]$ sudo chmod +w 5887_cover.pdf
> Password:
> chmod: changing permissions of `5887_cover.pdf': Operation not permitted
> yet using gnome file browser I can change permissions on these nfs 
> mounted files just fine - go figure.
> This did work in the past - so what has changed?
> how do I check what version of nfs is actually working?
>  [rkampen at robsws p_494]$ mount
> on /NDG type nfs (rw,noatime,intr,addr=
> Any thoughts?
man pages are your friends

man exports

Very often, it is not desirable that the root user on a client machine
is also treated as root when accessing files on the  NFS  server.  To
this  end,  uid  0 is normally mapped to a different id: the so-called
anonymous or nobody uid. This mode of operation (called ‘root squash-
ing’) is the default, and can be turned off with no_root_squash.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.