[CentOS] nfs (v3?) fails to allow writes and permission changes

Tue Jul 14 01:58:38 UTC 2009
Rob Kampen <rkampen at kampensonline.com>

Craig White wrote:
> On Mon, 2009-07-13 at 16:32 -0400, Rob Kampen wrote:
>> nate wrote:
>>> Rob Kampen wrote:
>>>> [rkampen at robsws p_494]$ sudo chmod +w 5887_cover.pdf
>>>> Password:
>>>> chmod: changing permissions of `5887_cover.pdf': Operation not permitted
>>>> yet using gnome file browser I can change permissions on these nfs
>>>> mounted files just fine - go figure.
>>>> This did work in the past - so what has changed?
>>>> how do I check what version of nfs is actually working?
>>> Root squash may be enabled by default, try adding the
>>> "no_root_squash" option to your exports file on the server
>>> side, you may need to remount the volume on the client side
>>> after restarting/reloading nfs on the server.
>>> nate
>>> _______________________________________________
>>> CentOS mailing list
>>> CentOS at centos.org
>>> http://lists.centos.org/mailman/listinfo/centos
>> tried that and that now normal chmod as me works okay but sudo chmod 
>> still not permitted.
>> I tried dragging a file to my desktop, opening and saving back to 
>> desktop works fine. Drag from desktop back onto folder via the file 
>> browser also works fine! So I guess nfs is okay?
>> BTW
>> chmod +w file.doc
>> only changes permissions for owner and group - world is left untouched, 
>> not what I remembered, I guess some man reading coming my way.
>> So now it seems what I have is an Openoffice problem. It writes odt 
>> files just fine via nfs but not doc files.
>> Must be a micro$oft conspiracy.
>> I'll take this off list as it does not appear to be a CentOS issue.
>> Thanks for the help.
>> Rob
> ----
> if the 'mount' is done as a 'user' mount but then you switch to su with
> sudo command, this would be a likely result.
> Craig
Is there any way to know what level (version) of nfs is in use?
I know how to distinguish between v4 and the rest (the mount uses nfs4 
rather than just nfs) but how about the lower levels?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: rkampen.vcf
Type: text/x-vcard
Size: 196 bytes
Desc: not available
URL: <http://lists.centos.org/pipermail/centos/attachments/20090713/194221e7/attachment-0005.vcf>