[CentOS] Conflicting perl packages?

Thu Jul 16 07:53:27 UTC 2009
Les Bell <lesbell at lesbell.com.au>

Marko Vojinovic <vvmarko at gmail.com> wrote:

The simple ordinary yum update of CentOS 5.3 spits a bunch of
transaction check errors regarding packages
perl-IO-Compress-Zlib-2.015-1.el5.rf.noarch and
perl-IO-Compress-2.020-1.el5.rf.noarch which is supposed to replace

I had the same problem on one system, which was niggling at the back of my
mind. I fixed it by brute force:

rpm -e --nodeps perl-Compress-Zlib perl-IO-Compress-Zlib
yum install perl-IO-Compress

Ugly, but it works. I also noticed some messages when restarting
amavisd-new, relating to error loading optional module . . . DKIM.pm, which
*might* be related (hadn't noticed it before, but it was also appearing on
another system which didn't have the Zlib errors above). Easily fixed with

yum install perl-Mail-DKIM

I did this half an hour or so ago, and everything seems to be running

Filipe Brandenburger <filbranden at gmail.com> wrote:

yum --skip-broken update

I tried that, as well as setting skip_broken in /etc/yun.conf, but the Zlib
errors aborted the entire transaction every time, forcing me to update
other packages one by one. That's what motivated me to do the hack above.


--- Les Bell
Tel: +61 2 9451 1144