[CentOS] Network guru please help: baffled by missing file

Fri Jul 17 13:48:14 UTC 2009
Timothy Murphy <gayleard at eircom.net>

Stephen Harris wrote:

> On Fri, Jul 17, 2009 at 01:14:26PM +0100, Timothy Murphy wrote:
>> The mirrorlist entry in my Fedora-11 /etc/yum.repos.d/fedora-update.repo
> [...]
>> Any and all suggestions gratefully received.
> This is a list for CentOS, not Fedora.  You'll get better help if you
> post to the right lists :-)

Sorry, I should have said that my server is running Centos-5.3.
If there is a problem on my system, it is at the server.
I ran wget on the server, and got the same result.
I also get the same result for EPEL:
[tim at helen ~]$ sudo yum update
Loaded plugins: downloadonly, fastestmirror, priorities, protect-packages, 
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist 
http://mirrors.fedoraproject.org/mirrorlist?repo=epel-5&arch=x86_64 error 
[Errno 14] HTTP Error 404: Not Found
Error: Cannot find a valid baseurl for repo: epel
using the mirrorlist line in /etc/yum.repos.d/epel.repo :

Also wget fails similarly:
[tim at helen ~]$ wget http://mirrors.fedoraproject.org/mirrorlist
--14:43:39--  http://mirrors.fedoraproject.org/mirrorlist
Resolving mirrors.fedoraproject.org...
Connecting to mirrors.fedoraproject.org||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
14:43:39 ERROR 404: Not Found.
This machine is running x86_64 CentOS:
[tim at helen ~]$ cat /etc/redhat-release
CentOS release 5.3 (Final)

Timothy Murphy  
e-mail: gayleard /at/ eircom.net
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College Dublin