[CentOS] Network guru please help: baffled by missing file

Fri Jul 17 15:11:21 UTC 2009
Timothy Murphy <gayleard at eircom.net>

Per Qvindesland wrote:

> Are you behind a proxy?

I don't think so.
My server is connected to an ADSL modem which links it to my ISP.
I don't know if the modem (Cayman 3341) could be acting as a proxy server?

I'm running shorewall on the server,
but I get the same response when I turn it off.

As I said, it seems to me that mirrors.fedoraproject.org
for some reason does not like my system.
I can connect to this site, and download files from it,
eg index.html, static/css/fedora.css, etc.
It is just the files mirrorlist and metalink
which I cannot see.

I never get this problem in any other context, as far as I know.

> If there is a problem on my system, it is at the server.
> I ran wget on the server, and got the same result.
> I also get the same result for EPEL:
> ---------------------------------
> [tim at helen ~]$ sudo yum update
> Loaded plugins: downloadonly, fastestmirror, priorities,
> protect-packages,
> protectbase
> Loading mirror speeds from cached hostfile
> Could not retrieve mirrorlist
> http://mirrors.fedoraproject.org/mirrorlist?repo=epel-5&arch=x86_64
> error
> was
> [Errno 14] HTTP Error 404: Not Found
> Error: Cannot find a valid baseurl for repo: epel
> ---------------------------------
> using the mirrorlist line in /etc/yum.repos.d/epel.repo :
> Also wget fails similarly:
> ---------------------------------
> [tim at helen ~]$ wget http://mirrors.fedoraproject.org/mirrorlist
> --14:43:39-- http://mirrors.fedoraproject.org/mirrorlist
> Resolving mirrors.fedoraproject.org...
> Connecting to mirrors.fedoraproject.org||:80...
> connected.
> HTTP request sent, awaiting response... 404 Not Found
> 14:43:39 ERROR 404: Not Found.
> ---------------------------------

Timothy Murphy  
e-mail: gayleard /at/ eircom.net
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College Dublin