[CentOS] install DVD mounted -noexec by default == bad interpreter permission denied

Tue Jul 28 18:52:52 UTC 2009
Dave <tdbtdb+centos at gmail.com>

On Tue, Jul 28, 2009 at 1:04 AM, William L. Maltby
<CentOS4Bill at triad.rr.com> wrote:
> In bash, you could probably stil run it with the "source" or ","
> command, e.g.
> . <the path to the script>
> source <the path to the script>

Nope, in desperation I tried those also, to no avail. My problem was
that the disk was mounted noexec, and the OS refuses to run scripts
that are located on partitions mounted noexec. From my history file:

 334  . /media/MATHWORKS_R2009A/install

In fairness to previous responder James, I am not 100% sure he is
wrong, since the final form of the command I ran was indeed

  366  sh  /media/MATHWORKS_R2009A/install &

But I am pretty sure I had tried that form previously, and failed
until I invoked:

  365  mount -o remount -o exec /dev/scd0

I am going by memory on that, because I was swapping shells in a way
that makes my history file sort of spotty. So it is just possible he
is right. So if someone finds themselves with a script on a DVD that
spouts this error message, they should try both the fixes and see
which one works. Or both?