[CentOS] please help: Linux Kernel must be loaded before initrd

Rudi Ahlers rudiahlers at gmail.com
Sun Jun 7 11:34:58 UTC 2009


Hi,

One of my servers in a IDC in another country mysteriously went down this
morning, and when I contacted the IDC, I was told that XEN doesn't boot up,
as follows:

[QUOTE]
This is error message on the screen " Error 19: Linux Kernel must be loaded
before initrd"

Server is currently up with 2nd kernel.

Please check the grub.conf.
[/QUOTE]

Looking at grub.conf, I see the following:

#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.18-128.1.10.el5xen)
        root (hd0,0)
        kernel /xen.gz-2.6.18-128.1.10.el5 ro root=/dev/VolGroup00/LogVol01
ide0=noprobe ide1=noprobe
        initrd /initrd-2.6.18-128.1.10.el5.img
title CentOS (2.6.18-128.1.10.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-128.1.10.el5 ro root=/dev/VolGroup00/LogVol01
ide0=noprobe ide1=noprobe
        initrd /initrd-2.6.18-128.1.10.el5.img
title CentOS (2.6.18-128.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-128.el5 ro root=/dev/VolGroup00/LogVol01
ide0=noprobe ide1=noprobe
        initrd /initrd-2.6.18-128.el5.img







Then on another server, I see the following in grub.conf:
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu

title CentOS (2.6.18-8.1.15.el5xen)
        root (hd0,0)
        kernel /xen.gz-2.6.18-8.1.15.el5
module /vmlinuz-2.6.18-8.1.15.el5xen ro root=/dev/VolGroup00/root
module /initrd-2.6.18-8.1.15.el5xen.img

title CentOS (2.6.18-8.1.15.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-8.1.15.el5 ro root=/dev/VolGroup00/root
        initrd /initrd-2.6.18-8.1.15.el5.img

title CentOS (2.6.18-8.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/root
        initrd /initrd-2.6.18-8.el5.img






On both kernels, I can see that initrd is loaded 2nd, as it should. So the
error doesn't make sense. The BIG problem is that the server is on another
continent, and their support is totally useless. I have actiall ordered a
new server, from another IDC and got it last night,  but need XEN to work on
this server in order to move the domU's across.

Can anyone see anyting wrong with this? Google has revelaed the obvious,
that the initrd is incorrectly loaded, but according to the grub.conf that I
have, it should be loading properly.

-- 
Kind Regards
Rudi Ahlers
CEO, SoftDux Hosting
Web: http://www.SoftDux.com
Office: 087 805 9573
Cell: 082 554 7532
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20090607/3dfcb5a3/attachment.html>


More information about the CentOS mailing list