[CentOS] RealTek 8168B (Rev 02) Issue

Tosh toshlinux at gmail.com
Tue Jun 9 13:15:29 UTC 2009

Ben Mohilef wrote:
> It is an D945GCLF2 with a 330.
>>  use the r8169 driver
> That driver has issues with the counters, resolved with the ElRepo and
> Realtek drivers. Ifconfig shows no dropped packets with the latter two
> drivers.
>>  website, it has been working fine, and I regularly check my tcpdump,
>>  dmesg even states that it enter promiscuous mode and exits > device
>>  eth0 entered promiscuous mode > device eth0 left promiscuous mode only
> The dmesg statement comes from a printk statement in the driver. I
> modified the driver to force the register to always load
> rx=AllowMe|AllowAll|AllowBroadcast|AllowMulticast.
> I surrounded it with printk statements so I know that it is entering and
> exiting the rx setting. It acts like this variable is never being
> written to the chip register. Hmmm, I think I need to look at their code
> some more to make sure they ARE writing to the register.
> Despite the kernel messages, the chip does not enter the promiscuous
> mode. If you have a second box talking to a third address, do you see
> that TCP traffic in TCPDump. Another way to check it is using iptraf.

iptraf shows packets, no problems here
So I run on two boxes iptraf and ping from on to another box, it shows 
me the ICMP req and reponse on both boxes
Also when I ping from the router, a linksys, it shows me the ICMP

BUT I found the following information :
even though bugzilla 452761 
(https://bugzilla.redhat.com/show_bug.cgi?id=452761) is solved by kernel 
2.6.18-128, bugzilla 474334 
(https://bugzilla.redhat.com/show_bug.cgi?id=474334) is only solved in 
kernel 2.6.18-141, so may need to use a kernel from Don Zickus before 
you can use them properly http://people.redhat.com/dzickus/el5/

Toshaan <toshlinux at gmail.com> - http://www.toshaan.be

More information about the CentOS mailing list