[CentOS] Things that fail over time (was Automounter (?) failing in CentOS 5.3)

MHR mhullrich at gmail.com
Wed Jun 10 20:06:43 UTC 2009


I'm starting a new thread on this because there are other failures I'd
like to bring up, not _necessarily_ directly related to CentOS, but
they all happen to me here.

FTR:
Linux mhrichter 2.6.18-128.1.10.el5 #1 SMP Thu May 7 10:35:59 EDT 2009
x86_64 x86_64 x86_64 GNU/Linux
(AMD 64x2 7750, 2.7GHz, 2GB memory, 900+GB disk, etc.)

I had a meeting to go to last night, so before I left, I rebooted.
When I returned, as I expected, my USB flash drives were all properly
recognized (i.e., the default behavior worked).  I have a number of
scripts and aliases that "depend" on certain flash drive cognizance,
but they all depend on indeirect references, so by changing, eg., my
symlink to my "main" flash drive, everything that "depends" on it
works just fine.  Of course, after the reboot, I had to restore the
original symlink, but I digress.

This particular failure might not actually have been time related,
although it seems like it because once it "began" to fail, it always
failed.  I tried all my USB ports, moved some connections around, and
only the flash drives continued to fail - my printers were fine (I had
to reset the hardware connection values in
System->Administration->Printers, but that's normal with a USB
disconnect/reconnect anyway if the ports are different.

I got onto this because I was using a USB extension cable for most of
my connects with the flash drives, and I was seeing some strange
behavior there, e.g., when I jiggled the flash drive, it would start
acting as if it had been unplugged and replugged.  I actually went
through and tested all my USB ports, some with and without the
extension cable, and I found one that just doesn't work at all (!),
but the behavior was consistent, except that I haven't retested that
extension cable yet - not sure I want to....


Another issue I'm seeing that is most clearly a time-related failure
is with flash videos in SeaMonkey.  I'm running:

Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b3pre)
Gecko/20090223 SeaMonkey/2.0a3

with most of the usual plugins, including the Adobe Shockwave Flash
10.0 r22 plugin.  This is the i586 aka 32-bit version.  I tried using
the 64-bit version, which I _think_ I got from rpmforge, but it just
doesn't work right, and it can't be installed simultaneously with the
32-bit version.  (I'm also using nspluginwrapper, of course, which is
really nice.)

The problem is that, after some indeterminate period of time, usually
overnight, the flash videos stop working properly.  They either load
for about 2 seconds and hang, or they play for 10-30 seconds with no
sound, then a burst of high-speed "catch-up" sound, then either
nothing or the echoes of the last fragment of sound, and so on.
Frequently, even when I close the offending tab, the sound takes up to
a minute or two to stop its echoes.  The only solution I've found is
to close SM altogether and restart it.  Then, all is well.

I realize that a) this isn't a CentOS issue per se, and b) I'm using
the 2.0 alpha test pre-release version of SM.  However, I have found,
through bitter experience and regret, that the standard release of
SeaMonkey 1.x is worse.  Now, I know there are some who will say "Use
Firefox," but, frankly, I really don't like the way too many of its
"featuers" work, and I really, _really_, REALLY prefer (a mild word
for it) the SeaMonkey/Netscape behaviors.

I should also note that it doesn't matter how many flash videos I play
that work, 0 or 1 or a dozen, once I hit that one that doesn't, it's
close all tabs and restart.  It's annoying, even when I just close the
thing SM and let its semi-automatic re-open all tabs on restart,
because usually that doesn't reestablish existing logins (it's kind of
intermittent there), and I am usually logged into Yahoo and Gmail all
the time.


There are also other failures I've seen that I can dimly recall and
that I thought at the time were time-related, and, miraculously! a
reboot solved them all, at least until the next time.  I don't
remember any of the specifics of those, and I haven't adopted the
practice of making notes on ALL of them yet, but it's just my
(primary) desktop, and I haven't seen anything remotely catastrophic
in those areas.  Yet.

So what?  I was wondering if anyone else had any thoughts on issues of
this nature (time-related failures).

Thanks.

mhr



More information about the CentOS mailing list