[CentOS] OT: rebuild kmod rpm package from src.rpm

carlopmart carlopmart at gmail.com
Thu Jun 11 08:55:57 UTC 2009


Hi all,

  I would like to rebuild a kmod.src.rpm package for a specific kernel. 
When I try to do it, this message appears:

Building target platforms: i686
Building for target i686
error: Failed build dependencies:
          kernel-xen-devel-i686 = 2.6.18-98.el5 is needed by 
mymodule-kmod-0.1.5-2.i686
         kernel-PAE-devel-i686 = 2.6.18-98.el5 is needed by 
mymodule-kmod-0.1.5-2.i686.

  Is it possible to rebuild kmod.src.package only for certain kernel?? i 
don't need to rebuild this module for kernel-xen or kernel-PAE only for 
kernel-i686 ...

  Thanks.
-- 
CL Martinez
carlopmart {at} gmail {d0t} com



More information about the CentOS mailing list