[CentOS] Minor dovecot/KMail problem

Timothy Murphy gayleard at eircom.net
Sat Jun 20 12:43:01 UTC 2009


I'm running a dovecot/IMAP server under CentOS-5.3 on my desktop,
reading the mail with KMail on my laptop.

I have what seems a venerable and well-documented problem/bug;
when I click on "Check Mail" I get an error message
"Error while getting folder information" ...
Actually, this doesn't appear to have the slightest effect
on kmail, which works perfectly if one just presses Continue.

But I have worked out that the cause of the problem
is that there exists a kind of ghost folder, "uidvalidity",
which is listed among the folders on the kmail page
but does not in fact seem to exist in my maildir on the server.

Deleting the folder under kmail has no permanent effect;
it simply re-appears when I re-start kmail.

I assume the folder is listed in some way in the dovecot.index ;
and my question really is: if I delete this index file
will it be re-created automatically?

This bug/feature seems to have been present for years,
which I suppose is par for KDE.
To make it as difficult as possible to diagnose,
the error message on the kmail page is incomplete,
even when expanded to the whole screen.
In particular it does not specify (on the visible part)
what folder is causing the problem.
Nor is the error listed with other dovecot information
in /var/log/messages .

Any suggestions/advice gratefully received.


-- 
Timothy Murphy  
e-mail: gayleard /at/ eircom.net
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College Dublin 





More information about the CentOS mailing list