[CentOS] Problems printer PS 1.1 vs. 1.3/1.4

Mon Mar 2 20:53:34 UTC 2009
MHR <mhullrich at gmail.com>

I just ran into a most interesting situation.  I am running CentOS 5.2
(2.6.18-92.1.22.el5) x86_64 with all the latest updates.

I recently converted a TIF to a PDF using tiff2pdf, and then tried to
print the file.  Now, this has worked for me many times in the past,
so I wasn't expecting any trouble at all.

Instead, my printer, a Brother 2140 laser printer, which has printed
these kinds of PDF files before without any problems, began spitting
out the PS text instead.

I did some poking around and found out that the PDF created by
tiff2pdf was format 1.1.  Another file I printed a few moments later,
which I had scanned in, was PDF format 1.4, and it printed fine, as
did the test page from System->Administration->Printer.

I fired up my VMWare Windows guest, used Adobe Photoshop Elements 2.0
(an old version), converted the TIF using that, and lo and behold, the
PDF is now in format 1.4.  That one printed just fine.

I'm running Adobe Reader 7.0.8 (mainly because AR 8.x never integrated
properly into my web browsers, and, more importantly, I could not find
a way to make it scale PDFs to fit my printers properly), so that
_might_ be part of it, but, as I said, I have done this numerous times
in the past and NEVER had a problem with it.  Until now.

Any clues what could be the problem?  Anyone had better luck with a
newer version of AR?