[CentOS] Cannot open port 631 for Cups printer sharing

Mon Mar 2 16:50:20 UTC 2009
Roger Wells <ROGER.K.WELLS at saic.com>

JohnS wrote:
> On Mon, 2009-03-02 at 11:20 -0500, b.j. mcclure wrote:
>> I have been trying to set up printer sharing on the LAN.All machines are
>> CentOS 5.2 fully updated. The problem server is a fresh build.  The box
>> it is replacing worked fine for many months.
>> The problem appears to be a closed port 631 on the new box.  iptables
>> and ip6tables are stopped as shown by the output below.  To confirm I
>> was using nmap correctly I ran it against the old server first which
>> shows 631 open.  No matter what I do to the new box ( 631
>> remains closed.  I was running it on the new box via ssh which I think
>> eleminates any swithc/router issues.
>> Any thoughts gladly accepted.  This must be something simple/stupid I
>> have overlooked.  Not much hair left to pull out. ;-/
> Do you have the Cups Service running? service cups status and service
> hplip status.
I don't have an answer but I have to believe that your problem
is related to mine (thread: cups & hp-toolbox)
my machine: Linux rwells-rh 2.6.18-92.1.22.el5 #1 SMP Tue Dec 16 
12:03:43 EST 2008 i686 i686 i386 GNU/Linux
[root at rwells-rh legacydp]# /sbin/service hplip status
hpiod (pid 6422) is running...
hpssd (pid 6427) is running...

[root at rwells-rh legacydp]# /sbin/service cups status
cupsd (pid 6453) is running... is my IP address
[roger at rwells-rh legacydp]$ nmap -sT -p 631 -PT

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2009-03-02 11:34 EST
Interesting ports on rwells-rh (
631/tcp closed ipp

Interesting that when the local host address is used the port is open:
[root at rwells-rh legacydp]# nmap -sT -p 631 -PT

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2009-03-02 11:47 EST
Interesting ports on localhost.localdomain (
631/tcp open  ipp

Nmap finished: 1 IP address (1 host up) scanned in 0.017 seconds

I hope that there are some clues here
> JohnStanley
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Roger Wells, P.E.
221 Third St
Newport, RI 02840
401-847-4210 (voice)
401-849-1585 (fax)
roger.k.wells at saic.com