[CentOS] Cannot open port 631 for Cups printer sharing ((SOLVED))

Mon Mar 2 21:58:45 UTC 2009
JohnS <jses27 at gmail.com>

On Mon, 2009-03-02 at 16:44 -0500, b.j. mcclure wrote:
> On Mon, 2009-03-02 at 16:23 -0500, JohnS wrote:
> > On Mon, 2009-03-02 at 15:46 -0500, b.j. mcclure wrote:
> > 
> > > I think the first problem is we have somehow merged two threads.  The
> > > first was Mr. Wells issue which is different from mine.  His port 631 is
> > > "open" when nmap is run from localhost but not when run against the IP.
> > > My port 631 is closed regardless of whether it is run from localhost or
> > > remotely against the IP.  My cupsd.conf works.  An identical machine
> > > co-located has an identical cupsd.conf and shares the same printer
> > > nicely on the same LAN.  The same nmap configuration run against that
> > > machine shows port 631 open in both above cases.  My conclusion, FWIW,
> > > is that it is not a cups config issue but a port issue.  
> > > 
> > > Also, the cups site link confirms that @LOCAL means local network which
> > > is all I'm looking for.  The laserjet 1300 has been supported for at
> > > least a few years now.
> > Correct
> > 
> > Lets get something straight. You "B.J"  are using a machine to be a
> > spooler for clients? 2 machines exactly? 2 machines acting as Spooler
> > Servers? Correct? The main issue is Clients can not see (connect) to the
> > machine because no open port.
> > 1. Can the spooler machine in question print locally?
> > 2. Whats the RPM version for cups
> > 
> > JohnStanley
> Sorry for the confusion.  I am replacing a box that acts as a print
> server for a LAN consisting of 11 machines, all running centos 5.2, and
> occasionally a lappie or two thrown in. The new box is/was the machine I
> had the issue on.  It now appears to be "solved" after I scp'd the
> config file over for the second time.  Not sure what I clutzed up the
> first time but the config file was apparently the issue.  Since I
> overwrote the offending config file I have no way of knowing what the
> difference was.  Looking at the working config file it appears to me to
> be box stock, as was the non-working one.
> Thanks much for all the help and my apologies for being a bit pig-headed
> about the config file.
Yea your a Pig Head because I wanted to see the original config file.
Something had to be different.
Next time use a tool called diff or zdiff.  Ok I guess your not a Pig

Just think you could have solved it today at 1:21PM EST! :-) Since it is
working I have some huge PDFs that need printing. Where do I submit