[CentOS] LSI Logic MegaRAID 8480 Storage controller

Tue Mar 10 19:38:33 UTC 2009
drew einhorn <drew.einhorn at gmail.com>

On Mon, Mar 9, 2009 at 11:14 AM, Joseph L. Casale
<JCasale at activenetwerx.com> wrote:
>>There is a MegaCLI command line interface that runs under the operating
>>system.  Normally I prefer command line tools.  But this software is big,
>>and complex.  All I have been able to find is a reference manual,
>>that has lots of typos and is not very well organized for me to learn
>>what I need to know.  I have not been able to find a tutorial for this
>>software.  It will take more time than I have at the moment to figure
>>out this tool.
> Huh? It's one tiny binary, and the syntax is trivial? You are looking at
> something else... Its own help is decent and it installs via rpm on RHEL.

> What you need is the mr_sas_sw_ug.pdf from lsi's site.

The manual IS sloppy.
missing - characters in the syntax

Tryijng to figure out -Val syntax

megacli ­AdpPRSetDelay ­-Val

+ /home/drew/bin/MegaCli -AdpPRSetDelay 0 -a0
Invalid input at or near token -AdpPRSetDelay

Tried sticking a - in front of the zero.  Doesn't make
much sense, tried it anyway, didn't help.

This cheat sheet for another vintage of the controller
rebadged by Dell, seems to be exactly what I need.


Looks like I can get most of what I need, without any
stinking -Val

That will do for now.
Drew Einhorn