[CentOS] [Fwd: Re: Another rpm question re %make]

Tue Mar 31 22:29:44 UTC 2009
Ross Walker <rswwalker at gmail.com>

On Mar 31, 2009, at 1:55 PM, "James B. Byrne" <byrnejb at harte-lyne.ca>  

> On Tue, March 31, 2009 13:03, James B. Byrne wrote:
>> Found it. No etc/at.allow and no etc/at.deny means only root can
>> submit jobs.
> Well, that was not it. I still get the same errors after adding my
> user id to /etc/at.allow.  I tested whether job control was enabled
> by moving top into the background using ctrl-z and fg to return and
> that worked.  Any suggestions as to what I am missing?  I sure this
> problem is only ignorance on my part.

Try installing ksh and see if that helps.

Also issuing --target= isn't enough for most builds, you also need  
your external build environment to report i386 or some part of the  
build process might start pulling in x86_64 libraries.

To do that you can try issuing an 'arch i386 rpmbuild -ba -- 
target=i386 <your spec file>' the 'arch i386' sets up the environment  
to report the machine is i386. That doesn't work everywhere, that is  
why mock or Xen or VMware with a full i386 environment is the  
recommended approach.

Personnally I like Xen as it comes with the OS and using virt-install  
getting another CentOS PV guest os is relatively quick. Others prefer  
mock still others VMware. Only mock and Xen can do it in a text-only