[CentOS] rpm and yum issues

Monty Shinn montys at videopost.com
Wed Nov 4 16:04:42 UTC 2009


I am having issues with rpm/yum on a centos 5.2 x86_64.

I am trying to update from 5.2 to 5.4.  During yum update, the
application became unresponsive during the package search.  It had not
begun to download any packages.

I tried to do a "yum clean all", but that wouldn't complete either.  I
tried to do a rpm --rebuild, but that failed with a segmentation fault.
Tried it a couple of times...  Reboot didn't work.  I copied the
database files out of /var/lib/rpm to a safe location, then deleted the
__db.* files.  Ran rpm --initdb.  That seemed to work.  Now, I've been
running rpm --rebuild for around 18 hours. 

The load factor on the server is 1.0, according to uptime.  Top shows
that it is running, using 100% cpu.  Iostat shows around 25% usr load.

I see the os raid drives bounce on occasion.

ps -ef shows the following daemons running (applicable to rpm):

/usr/lib/rpm/rpmd --rebuilddb
/usr/lib/rpm/rpmq -q --all --qf %{name}-%{version}-%{release}.%{arch}.rpm\n

A search of google led to no real help, but I may be searching wrong...

Here are the specs:

Centos 5.2
kernel: 2.6.18-92.1.6.el5 #1 SMP
2 xeon 3.20ghz procs, 4 logical

I can't get the rpm or yum version, since rpm is still running.

This is a stock install, using the xfs kmod.  Only non-standard app
installed is the 3ware utilities.  I have run a yum update on another
64bit box (almost identical hardware) and a 32 bit box with no
problems.  The boxes were at 5.2 and 5.0, respectively.

Any thoughts?



More information about the CentOS mailing list