[CentOS] rpm and yum issues

Craig White craigwhite at azapple.com
Wed Nov 4 16:47:50 UTC 2009

On Wed, 2009-11-04 at 10:04 -0600, Monty Shinn wrote:
> I am having issues with rpm/yum on a centos 5.2 x86_64.
> I am trying to update from 5.2 to 5.4.  During yum update, the
> application became unresponsive during the package search.  It had not
> begun to download any packages.
> I tried to do a "yum clean all", but that wouldn't complete either.  I
> tried to do a rpm --rebuild, but that failed with a segmentation
> fault.
> Tried it a couple of times...  Reboot didn't work.  I copied the
> database files out of /var/lib/rpm to a safe location, then deleted
> the
> __db.* files.  Ran rpm --initdb.  That seemed to work.  Now, I've been
> running rpm --rebuild for around 18 hours.
I would probably just stop the rpm --rebuild and copy everything back
from your backup of /var/lib/rpm and just...

rm /var/lib/rpm/__db.*
rpm --rebuilddb

shouldn't take very long and should be ok.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the CentOS mailing list