[CentOS] Virtualization option at first install CentOS-5.4 x86_64

James B. Byrne byrnejb at harte-lyne.ca
Fri Nov 6 21:21:08 UTC 2009

On Fri, November 6, 2009 13:50, James B. Byrne wrote:
> Evidently, one gets XEN.  I will get kvm from extras and go about
> installing it manually.

# grep 'vmx' /proc/cpuinfo

flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr
pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 cx16 xtpr

I installed kvm.x86_64-83-105.el5_4.9 successfully.  I also
installed virt-manager.  I tried to install qemu but failed due to
this file conflict:

Transaction Check Error:
  file /usr/share/man/man1/qemu-img.1.gz from install of
qemu-0.9.0-4.x86_64 conflicts with file from package

I infer from this that qemu is NOT required with KVM and that
kvm-qemu takes its place.

Proceeding to the next stage I tried to load the kvm-module:

# modprobe kvm-intel

Which fails like this:

FATAL: Error inserting kvm_intel
Operation not supported

So, what is going on?  What am I missing?  The CentOS HowTos on kvm
do not cover the current kernel insofar as I can see.


***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3

More information about the CentOS mailing list