[CentOS] Virtualization option at first install CentOS-5.4 x86_64

Les Mikesell lesmikesell at gmail.com
Tue Nov 17 06:33:33 UTC 2009

David McGuffey wrote:
> On Sat, 2009-11-07 at 23:32 -0600, Les Mikesell wrote:
>> David McGuffey wrote:
>>> I tried VMWare's EXSi 4.0 on bare metal, and failed.  Then I tried
>>> VirtualBox on CentOS 5.3 and failed.
>> What did these fail to do?
> Sorry it has taken so long to get back.
> After screwing around for weeks trying to get a motherboard that at
> least was on the unofficial white list, I did get EXSi 4.0 to load.  It
> was then that I realized I needed a separate Windoze workstation to load
> the vSphere to manage the VMs. I could only dedicate one machine to the
> virtualization testing.

If you set the VM's up with their own remote access (remote X, freenx, vnc, 
remote desktop, etc.) you only need the vSphere console to do the initial 
installs to the point where networking is up on the VM.

> Then I tried VB on CentOS 5.3.  For some reason, I couldn't get it to
> create a VM.  So...

That doesn't make much sense.

> I reloaded the machine with CentOS 5.4 (it had come out during my test),
> and selected 'kvm' during the install.  That worked great.
> At work, I loaded VB onto a Windoze XP Pro load and it locked up the
> machine.  Corporate IT had to re-image it...along with a warning to me
> about mucking with their standard load.

It works OK on XP for me - but wouldn't that box have been a suitable place for 
the vSphere client?

> Tonight, I just loaded VB onto Windoze XP 64.  The load went OK, but
> when I created a VM for CentOS 5.4 (text mode), it hangs trying to bring
> up the network.  That is the second failure I've had with VM.

There are several options for the network - are you using bridged or NAT?  And 
does the console show it as connected?

> Tomorrow I'm going to remove VB from the XP 64 load and install VMWare
> Server.

That should work too - although if you only plan to run one VM at a time and 
view its console locally you might as well use VMware player.

> At this point in time, the only virtualization tool that loaded and
> 'just worked' has been kvm under CentOS 5.4.  And...this is only a
> "Technology Preview" by Red Hat.  For a TP, I'm impressed.

I don't think you can blame the other products for 'not working'.

    Les Mikesell
      lesmikesell at gmail.com

More information about the CentOS mailing list